Off-Topic – Zimbra Installation on CentOS Host File Error

Okay so this is a little off topic from PowerShell but I had to post this, since I spent a couple days struggling with this, and a lot of time on google and didn’t find an answer that worked for me. Now that I figured out my problem, I have to blog about it so hopefully, someone, somewhere will be saved by this if it ever pops up in Google.

So here’s the error I was receiving:

ERROR: Installation can not proceeed. Please fix your /etc/hosts file
to contain:

<ip> <FQHN> <HN>

Where <IP> is the ip address of the host,
<FQHN> is the FULLY QUALIFIED host name, and
<HN> is the (optional) hostname-only portion

Okay, that sounds simple enough doesn’t it? Just go pop open my /etc/hosts file and make sure I have the usual bits in there. Did that. Same error. No matter how I formatted my hosts file.

For the record, here’s what was in my hosts file

192.168.56.68 mail.mydomain.com mail
127.0.0.1 localhost.localdomain localhost

Looks golden to me. Even flipping the FQDN and the hostname didn’t fix the problem.

Finally, I found it.

My hostname in my configuration was set to the FQDN of mail.mydomain.com when in reality it should have just been mail, without the domain. Configured that properly, and voila, Zimbra installs no problem.

*Facepalm*

I really do hope this helps someone, somewhere, sometime.

#I’mGoingBackToWindows

Leave a Reply

Your email address will not be published. Required fields are marked *